software that works

...needs to be done before upgrading OS X to 10.7 or higher!

Starting with Mac OS 10.7, Rosetta is no longer supported by Apple. This means that ForgotIt 1.4 does not run on OS X 10.7 "Lion" or higher. However, ForgotIt 2 cannot read old databases and migrating existing password databases to ForgotIt 2 and higher requires the existence of a running copy of ForgotIt 1.4. Consequently, you have to install the latest version of ForgotIt 2 and migrate your documents using the Import ForgotIt 1.4 Documents wizard in ForgotIt 2 before upgrading OS X to version 10.7 or higher!

To repeat, there is not way to read old ForgotIt 1.4 documents from within OS X 10.7 or higher, but you can transfer them with the help of ForgotIt 1.4 and ForgotIt 2 in any prior version of OS X running Rosetta. So please, migrate you password documents first, and then upgrade your Mac to the latest version of OS X.

Once you have ForgotIt 1.4 and ForgotIt 2 running on a system, please choose File > Import > Import > ForgotIt? 1.4 Import Wizard... and a 'wizard' type dialog will guide you through the migration process, which should take less than 5 minutes.